Installation issues

Questions and discussion regarding installation and getting familiar with Kumander Linux

Moderator: Bernadette

Post Reply
03HDFatboy
Posts: 3
Joined: Wed Jul 05, 2023 12:40 am
United States of America

Installation issues

Post by 03HDFatboy »

Keep getting grub efi amd64 package failed to install into /target/
User avatar
Roy
Site Admin
Site Admin
Posts: 95
Joined: Sat Apr 09, 2022 4:11 am
Real Name: Roy Hoejgaard
Most familiar OS: Kumander Linux
MBTI Type: INFP
Has thanked: 14 times
Been thanked: 8 times
Philippines

Post by Roy »

Hello there and welcome to the forum.

Yes, I think this is related with me making the Debian installer a bit too simple.

Are you installing on a secondary hard drive or as a dual boot with a previous system?

I made it so that the installer expects that the target drive for the Grub boot loader is the first hard disk available. When installing Kumander on a secondary hard disk, this can give problems.

Suggested fixes:
  • If dual booting, try to install Kumander first on the primary hard disk. Then install the second OS.
  • If installing on a secondary drive, try changing the installation target to the primary drive. And preferably do a full format first.
The problem can also be solved by booting into the ISO Live version after installing, and manually installing Grub from there. This link should give you some ideas.

This problem will be fixed for Kumander Linux 2.0.

Hope this helps,
Roy
03HDFatboy
Posts: 3
Joined: Wed Jul 05, 2023 12:40 am
United States of America

Post by 03HDFatboy »

Roy wrote: Wed Jul 05, 2023 11:01 pm Hello there and welcome to the forum.

Yes, I think this is related with me making the Debian installer a bit too simple.

Are you installing on a secondary hard drive or as a dual boot with a previous system?

I made it so that the installer expects that the target drive for the Grub boot loader is the first hard disk available. When installing Kumander on a secondary hard disk, this can give problems.

Suggested fixes:
  • If dual booting, try to install Kumander first on the primary hard disk. Then install the second OS.
  • If installing on a secondary drive, try changing the installation target to the primary drive. And preferably do a full format first.
The problem can also be solved by booting into the ISO Live version after installing, and manually installing Grub from there. This link should give you some ideas.

This problem will be fixed for Kumander Linux 2.0.

Hope this helps,
Roy
I figured it out, I had to change it to Legacy Boot from UEFI. Sounds crazy I know, I was running out of ideas and patience and it was the only thing I hadn't tried. I even tried different .iso writers on 3 different PC's
User avatar
Roy
Site Admin
Site Admin
Posts: 95
Joined: Sat Apr 09, 2022 4:11 am
Real Name: Roy Hoejgaard
Most familiar OS: Kumander Linux
MBTI Type: INFP
Has thanked: 14 times
Been thanked: 8 times
Philippines

Post by Roy »

Yes, not using Legacy Boot can also be an issue. Thanks for pointing it out.

Regards,
Roy
Kim Rowe
Posts: 1
Joined: Wed Aug 30, 2023 4:02 am

Post by Kim Rowe »

Are you running it on bare metal? If so is EFI or UEFI is enabled?
At APKTome, we believe that entertainment should not be about finances. That's why we offer free game Mod apk by apktome apps.
Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests